Requirements

Server

AldoContent has minimal requirements and executes on Web servers that meet the following configuration:

  • PHP 5.1, configured with the modules:
    • gd
    • gzip
    • gettext (optional)
  • MySQL 4.0 or newer.
  • Operating system: Linux, Solaris, FreeBSD, Windows (this last one wasn't tested but should execute with no problems).
  • HTTP Server: Apache (Preferred) or IIS (same as above).
  • Using of SEO friendly URLs requires Apache HTTPD with mod_rewrite intalled and permissions on the server to use local .htaccess file in the site root directory.
  • Regarding of the system interface internationalization was designed for using gettext, it is recommended that this service has been installed in the server (applicable in Unix Servers) with PHP gettext module compiled on it; if not installed as such, AldoContent will use the php-gettext emulator with a small decrease in the performance.
  • To send mail, AldoContent can be configured to use PHP mail function, or to connect to a SMTP server or to write to sendmail or wrapper directly.
  • In order to upload files or images using the AldoContent tools, the directories located to store upoloaded images and files on the server must have writting permissions.

Client

Visitors browsers

The visitor browser support is given by the Website design, the correct using of CSS and Javascript and is responsibility of Webdesigner. It is recommended to test the page lay-outs with as many browsers as possible.

  • Firefox 1.0.7 or newer.
  • Internet Explorer 6.0 or newer.
  • Mozilla 7.01 or newer.
  • Camino (Mac).
  • Safari. (Is known that this browser lacks complete CSS support).

For site editing

  • Internet Explorer 6.0 or newer.
  • Firefox 1.0.7 oor newer.
  • Mozilla 7.1 or newer
  • Camino
  • Safari is not cappable to work with FCKEditor, but is possible to edit the website turning of the wysiwyg feature on AldoContent.
  • The Web Browser must have enabled Javascript and cookies.
  • On Firefox and Internet Explorer 7.0 the opening of pop-up windows must be authorized for the Website domain where content is edited.
  • Firefox requires to be configured in order to use the FCKEditor icons to paste content, this is caused by the browser security policies, see the instructions.

Installation

  • An FTP client to uplad the files to the server, a graphic one, like Filezilla on Windows or gFTP for Linux.
  • Access to create MySQL databases on the webserver.
  • A pure text editor to edit the configuration files.

Author: maxmad
Created: 2007-0330 18:34 | Last modified: 2009-0728 20:54

SourceForge.net Logo

Recommend  Print  A- A+
Powered by: AldoContent